Datagram Transport Layer Security (DTLS o Protocolo de Seguridad de Capa de Transporte en español) es un protocolo que proporciona seguridad a las comunicaciones basadas en protocolos de datagramas. Este protocolo permite a las aplicaciones cliente/servidor comunicarse de manera que se eviten las escuchas no deseadas (eavesdropping), ataques de intermediario (MITM), o modificación de mensajes. El protocolo DTLS está basado en el protocolo TLS y proporciona garantías de seguridad equivalentes. La semántica de los datagramas de los protocolos subyacentes no es modificada al utilizar DTLS. Al ser usado principalmente junto con los protocolos UDP y SCTP, las aplicaciones que empleen DTLS para asegurar sus conexiones tendrán que lidiar con desorden de paquetes, pérdida de datos y un tamaño de paquetes mayor al de los paquetes de datagramas originales.
Definición DTLS está definido por diferentes documentos:
RFC 6347 para UDP. RFC 5238 para DCCP. RFC 5415 para CAPWAP. RFC 6083 para SCTP. RFC 5764 para SRTP.
Existen dos versiones de DTLS: la versión 1.0 (basada en TLS 1.1) y la versión 1.2 (basada en TLS 1.2)
Implementaciones OpenSSL: una implementación libre y popular. GnuTLS: una implementación libre bajo la licencia GPL. LibreSSL: implementación de código abierto del proyecto BSD. mbed TLS: originalmente desarrollada por Arm, liberada bajo la licencia Apache 2.0
Enlaces externos The IETF TLS Workgroup The Design and Implementation of Datagram TLS
Categoría:Protocolos de red