DNS mediante TLS (DoT, siglas en inglés de DNS over TLS) es un protocolo de seguridad para cifrar y ajustar las consultas y respuestas del sistema de nombres de dominio (DNS) a través del protocolo de seguridad de la capa de transporte (TLS). El objetivo del método es aumentar la privacidad y la seguridad del usuario mediante la prevención de escuchas ilegales y la manipulación de los datos del DNS a través de ataques de intermediario.
A partir de 2019, Cloudflare, Quad9, Google, Quadrant Information Security y CleanBrowsing ofrecen servicios públicos de resolución de DNS para el protocolo de seguridad DNS mediante TLS. El 9 de junio de 2025, DNS4EU también comenzó a ofrecer dicho servicio.En abril de 2018, Google anunció que Android Pie incluirá soporte para DNS mediante TLS con Google Public DNS. DNSDist, de PowerDNS también anunció soporte para DNS mediante TLS en su última versión 1.3.0. Los usuarios de BIND también pueden utilizar DNS mediante TLS con el software stunnel. Unbound soporta DNS mediante TLS desde el 22 de enero de 2018.
DNS disponibles públicamente
La implementación de un servidor DNS sobre TLS ya está disponible de forma gratuita por algunos proveedores de DNS públicos. Se ofrecen cuatro implementaciones para servidores en producción:
Proveedor Direcciones IP (IPv4, IPv6) Bloqueo Puerto DNSSEC CleanBrowsing 185.228.168.168 185.228.168.102a0d:2a00:1:: 2a0d:2a00:2:: Contenido para adultos 853 Cloudflare 1.1.1.1 1.0.0.1 2606:4700:4700::1111 2606:4700:4700::1001 853 DNS4EU 86.54.11.186.54.11.2012a13:1001::86:54:11:12a13:1001::86:54:11:201 Malware y phishing. 86.54.11.1186.54.11.2112a13:1001::86:54:11:112a13:1001::86:54:11:211 Malware, phishing, contenido para adultos y anuncios. 86.54.11.1286.54.11.2122a13:1001::86:54:11:122a13:1001::86:54:11:212 Malware, phishing y contenido para adultos. 86.54.11.1386.54.11.2132a13:1001::86:54:11:132a13:1001::86:54:11:213 Malware, phishing y anuncios. 86.54.11.10086.54.11.2002a13:1001::86:54:11:1002a13:1001::86:54:11:200 GooglePublicDNS 8.8.8.88.8.4.42001:4860:4860::8888 2001:4860:4860::8844 853 Quad9 9.9.9.9 149.112.112.1122620:fe::fe Dominios peligrosos. 853
Incidencias
A lo largo de su historia el DNS mediante TLS ha presentado una serie de incidencias, de las cuales las más importantes han sido las siguientes: El 11 de junio de 2019 en la versión 4.2.0 de NSD se añadió soporte para DNS mediante TLS, además de TCP Fast Open para dar la debida rapidez a las conexiones.
Véase también
DNS mediante HTTPS DNSCrypt DNS-based Authentication of Named Entities (DANE) DNSCurve
Notas
Referencias
Enlaces externos
Solicitudes de comentarios : : RFC 7858. : RFC 8310. : RFC 5966 (obsoleto), RFC 8490.
Categoría:Domain Name System Categoría:Protocolos de Internet Categoría:Protocolos de nivel de aplicación Categoría:Seguridad de redes informáticas